@alashworth has raised an issue that we have non-unique names for the unit test. This prevents any sort of work on jumbo (unity) builds of the unit tests. Having those would have a large benefit for test compile time, so this is very relevant.
To clarify, if we have
TEST(MathMatrix, inverse_exception) that same pair of names should not be used in any other test case in any other files in our codebase.
I imagine if I go and fix that in the current codebase that would not be an issue to anyone since its just a rename PR.
But how do you feel if we add this to be a requirement on PRs?
We can add a check to runChecks.py that enables the developers to double check this on their own and this will also be run on the Jenkins tests so no PRs with non-unique names could be merged.
I really dont want to add such a restriction on my own. It would definitely be added to the developer doc.
Tagging some developers that worked on Math recently.