Unable to install pystan 2.19 on RockyLinux 8.9 arm64

Hi All,
I am trying to install pystan on a rockylinux arm64 docker container. I’ve tried multiple things, including installing from source, but nothing is working.

Operating system (Docker base image) : RockyLinux 8.9, arm64.
Python Version : 3.8
Python devel Version : 3.8
Pystan Version :
Compiler : Tried with both gcc-toolset-9 and gcc-toolset-10.

Also tried installing from source using the following command :

pip install git+https://github.com/stan-dev/pystan2.git@master

All of these approaches end with the same error :

    INFO: gcc: pystan/stan/src/stan/lang/grammars/whitespace_grammar_inst.cpp
    {standard input}: Assembler messages:
    {standard input}:317314: Warning: end of file not at end of a line; newline inserted
    {standard input}:304879: Error: invalid operands (*UND* and .gcc_except_table sections) for `-'
    gcc: fatal error: Killed signal terminated program cc1plus
    compilation terminated.
    error: Command "gcc -pthread -Wno-unused-result -Wsign-compare -DDYNAMIC_ANNOTATIONS_ENABLED=1 -DNDEBUG -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -fasynchronous-unwind-tables -fstack-clash-protection -D_GNU_SOURCE -fPIC -fwrapv -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -fasynchronous-unwind-tables -fstack-clash-protection -D_GNU_SOURCE -fPIC -fwrapv -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -fasynchronous-unwind-tables -fstack-clash-protection -D_GNU_SOURCE -fPIC -fwrapv -fPIC -DBOOST_DISABLE_ASSERTS -DBOOST_NO_DECLTYPE -DBOOST_PHOENIX_NO_VARIADIC_EXPRESSION -DBOOST_RESULT_OF_USE_TR1 -DFUSION_MAX_VECTOR_SIZE=12 -Ipystan -Ipystan/stan/src -Ipystan/stan/lib/stan_math/ -Ipystan/stan/lib/stan_math/lib/eigen_3.3.3 -Ipystan/stan/lib/stan_math/lib/boost_1.69.0 -Ipystan/stan/lib/stan_math/lib/sundials_4.1.0/include -I/usr/include/python3.8 -c pystan/stan/src/stan/lang/ast_def.cpp -o build/temp.linux-aarch64-3.8/pystan/stan/src/stan/lang/ast_def.o -Os -ftemplate-depth-256 -Wno-unused-function -Wno-uninitialized -std=c++1y" failed with exit status 1

If someone could point me in the right direction that would be great. Thank you!

I think it supports python 3.7 (nothing newer).

Is there a specific reason you need PyStan 2.x?

I think it supports python 3.7 (nothing newer).

Do you mean pystan on arm only supports python <=3.7 ? We’ve been running pystan 2.19 on Centos7 (x86) with python 3.8 for quite some time now and it works.

I need PyStan 2.19 since that’s a dependency for prophet 1.0.1.

Ok, not sure about arm, but I think 3.7 was last one that worked more or less ok.

I assume then too that updating prophet does not work for you?

Ended up updating prophet to 1.1, that works. Thanks!

1 Like