[Solved] Pystan hang on mac - dependent on size of (small) data

[this time updating everything with conda update --all solved it…sorry for the noise]

I’m having an issue with pystan on the mac that I can’t seem to debug. I tried a few small examples, and it seemed to work, and then other examples it would hang after sampling. I found this example which hangs: https://github.com/fonnesbeck/stan_workshop_2016

In trying to figure out the issue, I made a self-contained version here: https://gist.github.com/bblais/24e863d561affc3c3977ed6e1e345e94

which hangs somewhere around N=100 (sometimes 90, sometimes 100, not always the same). It runs, and prints the following to the terminal:

Iteration: 600 / 1000 [ 60%] (Sampling)
Iteration: 700 / 1000 [ 70%] (Sampling)
Iteration: 800 / 1000 [ 80%] (Sampling)
Iteration: 900 / 1000 [ 90%] (Sampling)
Iteration: 1000 / 1000 [100%] (Sampling)

Elapsed Time: 0.022963 seconds (Warm-up)
0.020337 seconds (Sampling)
0.0433 seconds (Total)

and then simply hangs. The smaller data, say N=10 or N=30, runs nearly instantly. I’m not sure even how to debug this problem. Can anyone reproduce it? Any steps I can take to figure it out?


Operating System: Sierra 10.12.6
Python Version: Python 3.6.1 |Anaconda custom (64-bit)
Interface Version: pystan._version= '’
Compiler/Toolkit: gcc