./runTests.py only seems to work with clang++

I’ve tried to use the ./runTests.py script with g++, but I can’t get it to work. I tried following the instructions in the wiki page “Testing Stan using Gnu Make and Python”. I put “CXX=g++” in make/local (in the main Stan directory), and then when that didn’t work, I removed make/local and placed its content into ~/.config/stan/make.local. Neither of these kept the ./runTests.py script from spewing the following error messages:

make: clang++: Command not found
/bin/sh: 3: clang++: not found

I also got the error message “find: ‘stan’: No such file or directory”. Not sure if that’s a different problem or related to this one.

ETA: I figured out the problem. In the main Stan makefile are the following lines:

-include $(HOME)/.config/stan/make.local  # define local variables
-include make/local                       # overwrite local variables

CXX = $(CC)

That last line means that, contrary to the wiki page, any setting of CXX in the aforementioned include file will be ignored.

The original post from @jjramsey has been edited to include the solution.

Thanks for following up. It’s helpful if you answer the question in a separate post because then we can mark it as solved.