Progress not shown with update to rstantools (2.1.1)

After some updates this week, I no longer see model fitting progress in the R console

Previously, I would get a message staying the model was being compiled, then each worker/chain being initialized, then each chain’s progress through the warmup and sampling interations.

Now I only get a start sampling message until the run is finished and takes me back to a cursor.

This is with:
Ubuntu 20.04 64-bit,
R 4.0.2 ,
RStudio Server Version 1.3.959 and RStudio Version 1.3.959,
brms_2.13.4 ,
Rcpp_1.0.5 ,
rstan_2.21.1 ,
StanHeaders_2.21.0-5 ,

I have tried the following arguments without success:

silent = FALSE,
refresh = 1,
open_progress = TRUE,
verbose = TRUE,

Is there a way to bring progress monitoring back to the console?

1 Like

Is this RStudio or from a shell?

RStudio, I’ll add that to the initial post

I can confirm I also don’t get a printout when doing multiple cores on linux. I have the same setup as @JLC but I’m just using RStudio Version 1.3.959 and not Rstudio Server

I’ll post an issue on rstan

Actually I just installed from github and it’s printing all the chain info now. @JLC can you try installing from github?

remotes::install_github("stan-dev/rstan", ref = "develop", 
                        subdir = "rstan/rstan", build_opts = "")
1 Like

Are you using RStudio Server or RStudio Desktop?

Thank you, @stevebronder!

Installing from github solved the issue for me as well.

I had moved away from the dev version because I kept having StanHeader issues, but I’m up and running now.

Thanks again!


Rstudio desktop. I also just bumped up to Rstudio version 1.3.1056 because I was getting some really weird non Stan related crashes with 1.3.959

Another thank you! Moving to 1.3.1056 solved some memory overrun issues I’ve been seeing.