I wanted to take the time to go through a full program and provide comments on naming and commenting style. Hope this isn’t too presumptuous on my part.
My topmost comment is that I think you’ll find your code easier to read with fewer comments and fewer vertical spaces. And keeping indentation aligned—otherwise it’s too hard to see where scopes and loops/conditionals end. Don’t use tabs as you never know how they’ll render.
It’s usually better to choose an informative variable name rather than a uninformative one and then provide doc. Ndata
is too generic here, as there is a lot of data in the data block, hence the need for doc.
int<lower=1> Ndata; // Total number of trials (for all subjects)
Instead, I would suggest removing the doc and renaming the variable for clarity.
int<lower=0> num_trials;
Also, I switched lower bound to zero. Usually you want to allow zero data—that lets you do prior predictive inference by supplying empty data without changing the model.
I’d suggest putting <lower=1, upper=num_subjects>
on first_trial
and renaming it if the doc is right that it’s which subject performed each trial. It helps document the range of values so you don’t need to do that in the doc itself.
array[Ndata] int<lower=0> ch_card; //index of which card was chosen coded 1 to 4
If this has to take values 1 to 4 then it should be <lower=1, upper=4>
. Then you don’t need the doc—it’s built into the declaration. If you name the variable chosen_card
you can get rid of the rest of the doc.
The variables subject_trial
and first_trial
have the same doc, so presumably one is wrong, or more is needed to distinguish them.
If you really feel that mu_alpha
is too confusing, call it mean_learning_rate
. I don’t think it really is mean learning rate across subjects though, I think it’s the population-level location parameter, which doesn’t have to work out to the mean across subjects, though it sometimes will in simple cases.
The parameters you document as “Non-centered parameters” is in fact the raw parameters, not the non-centered ones. The non-centered ones are alpha_sbj
and beta_sbj
. You can do this all more easily by declaring
parameters {
vector<offset=mu_beta, multiplier=sigma_beta>[NSubjects] beta;
...
model {
beta ~ normal(mu_beta, sigma_beta);
I replaced beta_sbj
with just beta
, but that should be called something meaningful if beta
isn’t well known as a conventional name in this model.
I found the setting and unsetting of Q_cards
quite confusing. This would be much cleaner if you stored the starting index of each block, then iterated through the blocks. Then you could just initialize at the top of the loop.
Speaking of initialization, it’s best to define that rep_vector
in generated data block and reuse).
This is the kind of comment I’d suggest just eliminating as it’s just saying what the code is doing:
//calculating PEs
PE_card =reward[t] - Q_cards[ch_card[t]];
Similarly, the priors comments in the model block aren’t telling us anything we can’t derive from looking at the variables. Here they’re correctly named as “group-level parameters”.