Issues with PyStan3

Hello all, I am trying out PyStan3 and I have the following issues:

  1. There is no progress bar appearing when sampling is happening (I use pycharm 2020.1.4; updated, didn’t work). From a previous thread (How to show sampling progress in Python console?) my tqdm work normally.
  2. When I hit
    posterior =, data=data), I get the following error:

aiohttp.client_exceptions.ContentTypeError: 0, message='Attempt to decode JSON with unexpected mimetype: text/plain; charset=utf-8', url=URL('')

All data types and python dict worked with previous PyStan version.

Any help/suggestions will be welcomed!


how big is your model (data size)?

  1. pypi (pip) does not have it yet. Current github master has it, but using current master needs a bit of experience with our set up. See

Thanks! The data are matrices of 15x15x400 of either integers or floats.
I guess I will have to wait for the final PyStan3 release (any rough estimate when this could be?)

1 Like

UPDATE - 2 was solved by changing the httpstan/httpstan/ file. Thanks!

1 Like