Install issue: make build returning file existence errors

I have been trying to install Stan today to use with Matlab on Windows 10. I can’t seem to get cmdstan to build. After I’ve unpacked the folder and attempt to ‘make build’ in the command prompt I keep getting errors regarding files not being found. I’ve tried to ‘make clean-all’, but that also returns similar errors. Perhaps I’ve missed something important.

Has anyone had a similar issue?

File not found - *_inst.cpp
File not found - *_def.cpp
make/libstan:16: no file name for `-include’
File not found - *.stan
File not found - *.hpp
FIND: Parameter format not correct
g++ -Wall -I . -isystem -isystem -isystem /include -std=c++1y -DBOOST_RESULT_OF_USE_TR1 -DBOOST_NO_DECLTYPE -DBOOST_DISABLE_ASSERTS -DBOOST_PHOENIX_NO_VARIADIC_EXPRESSION -Wno-unused-function -Wno-uninitialized -I src -isystem stan/src -isystem stan/lib/stan_math/ -DFUSION_MAX_VECTOR_SIZE=12 -Wno-unused-local-typedefs -DEIGEN_NO_DEBUG -DNO_FPRINTF_OUTPUT -pipe -c -O3 -o bin/cmdstan/stanc.o src/cmdstan/stanc.cpp
src/cmdstan/stanc.cpp:1:41: fatal error: stan/command/stanc_helper.hpp: No such file or directory
#include <stan/command/stanc_helper.hpp>
compilation terminated.
make: *** [bin/cmdstan/stanc.o] Error 1

1 Like

Did you download the zip file that’s been packaged as a release?

If you download using the GitHub-provided zip download, it isn’t a complete download. It is missing the submodules which are required.

I’m on my phone so it’s not super convenient to find someone the releases, but hopefully it’s easy to get to from GitHub or the Stan website. If you can’t find it, please drop another note and I’ll look it up when I get back to a computer.

Thank you for the reply. Yes, I’ve used the release tar file. I’ve even tried using an older release and I still encounter a similar error when trying to build.

Thanks. I just noticed something that might indicate what’s wrong:

And… I just found it in the CmdStan documentation! It’s in the appendix.

Mind checking your path?

Thanks so much! I had Rtools in my path, but I didn’t think to bump it to the beginning of the path. I really appreciate it!

1 Like