Help: Compiling issue with R 4.2, New Install & User

Output from Console.txt (3.8 KB)

Hey, I created a fresh, first time install, and I can’t get my simple model to compile. I can see that RStudio recognizes Stan parser, but it does not compile my model. Is there something wrong with my install or script?

I put my console output of the error message, and my script. The model is something from Ben Lambert’s youtube channel.

Thanks for your time, guys!
Mike

  • Win 10
  • RStan Version 2.26.x (unreleased)
  • Output of:

readLines("~/.Renviron")
[1] “PATH=”{RTOOLS40_HOME}\\usr\\bin;{PATH}""
readLines("~/.Rprofile")
[1] “Sys.setenv(BINPREF = “C:/rtools42/usr/mingw_$(WIN)/bin/”)”
readLines("~/.R/Makevars.win")
[1] “”
[2] " CXX14FLAGS += -mtune=native -O3 -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2"
Sys.getenv(“PATH”)
[1] “C:\rtools42/x86_64-w64-mingw32.static.posix/bin;C:\rtools42/usr/bin;\usr\bin;C:\Program Files\R\R-4.2.0\bin\x64;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x86)\ZeroTier\One\;C:\Program Files\PuTTY\;C:\Program Files\Git\cmd;C:\Users\Mike\AppData\Local\Microsoft\WindowsApps;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x86)\Sophos\Sophos SSL VPN Client\bin”

  • Output of `devtools::session_info(“rstan”): > devtools::session_info(“rstan”)
    Error in loadNamespace(x) : there is no package called ‘devtools’

Yeah, so I guess my VAR was all messed up. I was a little unclear about the installation of rtools42, so I ended up mixing up the directions. I’ve cleared that up. Installation still doesn’t work, - but I guess this problem has been resolved.

See Stan & R 4.2 on Windows – The Stan Blog

Thanks rok_cesnovar. I’ll check this out!

It worked! Amazing. Thank you.

-Mike