Error Message (Object not found) with brms Developer Version on Ubuntu


#1

Hi there :)

I just installed the git_hub version of brms (2.7.4) on this system:

R version 3.4.4 (2018-03-15)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 18.04.2 LTS

and the following error message pops up regardless of which model I try to run.

Error message with traceback:

Error in eval(args[[i]], envir) : object '.x9' not found 
15.
eval(args[[i]], envir) 
14.
eval(args[[i]], envir) 
13.
assign(nms[[i]], eval(args[[i]], envir), envir = envir) 
12.
assign_args(dots[named], env) 
11.
.fun(.x1, .x = .x2, .sep = .x3, .envir = .x4, .open = .x5, .close = .x6, 
    .na = .x7, .transformer = .x8, .trim = .x9) at <text>#1
10.
eval(expr, envir, ...) 
9.
eval(expr, envir, ...) 
8.
eval2(call, envir = args, enclos = parent.frame()) 
7.
do_call(glue::glue_data, c(dots, args)) 
6.
glue("  int<lower=1> N{resp};  // number of observations\n") 
5.
stan_response(x, data = data) 
4.
stan_predictor.brmsterms(bterms, data = data, prior = prior, 
    ranef = ranef, meef = meef, sparse = sparse, stanvars = stanvars) 
3.
stan_predictor(bterms, data = data, prior = prior, ranef = ranef, 
    meef = meef, sparse = sparse, stanvars = stanvars) 
2.
make_stancode(formula, data = data, prior = prior, sparse = sparse, 
    cov_ranef = cov_ranef, sample_prior = sample_prior, knots = knots, 
    stanvars = stanvars, stan_funs = stan_funs, save_model = save_model) 
1.
brm(DV ~ 1, data = dataX, family = bernoulli()) 

The non-developer version ran fine on this system, and the developer version also runs on other systems. Any quick solution for what to do? I like to use this brm version on this particular machine :)

Thanks,
René


#2

Can you post your sessionInfo()?


#3

Sure:

R version 3.4.4 (2018-03-15)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 18.04.2 LTS

Matrix products: default
BLAS: /usr/lib/x86_64-linux-gnu/blas/libblas.so.3.7.1
LAPACK: /usr/lib/x86_64-linux-gnu/lapack/liblapack.so.3.7.1

locale:
[1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C LC_TIME=en_US.UTF-8 LC_COLLATE=en_US.UTF-8
[5] LC_MONETARY=en_US.UTF-8 LC_MESSAGES=en_US.UTF-8 LC_PAPER=en_US.UTF-8 LC_NAME=C
[9] LC_ADDRESS=C LC_TELEPHONE=C LC_MEASUREMENT=en_US.UTF-8 LC_IDENTIFICATION=C

attached base packages:
[1] parallel stats graphics grDevices utils datasets methods base

other attached packages:
[1] emmeans_1.2.4 brms_2.7.4 Rcpp_1.0.0 reshape2_1.4.2 afex_0.18-0 lsmeans_2.27-61 lme4_1.1-15 Matrix_1.2-15
[9] R2jags_0.5-7 rjags_4-6 coda_0.19-1 plyr_1.8.4 Hmisc_4.1-1 ggplot2_2.2.1 Formula_1.2-2 survival_2.41-3
[17] lattice_0.20-35 psych_1.7.8 pastecs_1.3.21

loaded via a namespace (and not attached):
[1] TH.data_1.0-8 minqa_1.2.4 colorspace_1.3-2 modeltools_0.2-21 ggridges_0.5.1 rsconnect_0.8.8
[7] estimability_1.3 htmlTable_1.11.2 markdown_0.8 base64enc_0.1-3 rstudioapi_0.7 rstan_2.18.1
[13] MatrixModels_0.4-1 DT_0.4 mvtnorm_1.0-7 coin_1.2-1 bridgesampling_0.6-0 codetools_0.2-15
[19] splines_3.4.4 mnormt_1.5-5 knitr_1.17 shinythemes_1.1.1 bayesplot_1.6.0 nloptr_1.0.4
[25] pbkrtest_0.4-7 cluster_2.0.6 shiny_1.1.0 compiler_3.4.4 backports_1.1.1 assertthat_0.2.0
[31] lazyeval_0.2.1 cli_1.0.0 later_0.7.5 prettyunits_1.0.2 acepack_1.4.1 htmltools_0.3.6
[37] quantreg_5.35 tools_3.4.4 bindrcpp_0.2 lmerTest_2.0-36 igraph_1.2.2 gtable_0.2.0
[43] glue_1.2.0 dplyr_0.7.4 nlme_3.1-131 crosstalk_1.0.0 stringr_1.3.0 ps_1.2.0
[49] mime_0.6 miniUI_0.1.1.1 gtools_3.5.0 MASS_7.3-49 zoo_1.8-1 scales_0.5.0
[55] colourpicker_1.0 promises_1.0.1 Brobdingnag_1.2-6 sandwich_2.4-0 inline_0.3.15 SparseM_1.77
[61] shinystan_2.5.0 RColorBrewer_1.1-2 gridExtra_2.3 StanHeaders_2.18.0 loo_2.0.0 rpart_4.1-13
[67] latticeExtra_0.6-28 stringi_1.1.6 dygraphs_1.1.1.6 checkmate_1.8.5 boot_1.3-20 pkgbuild_1.0.2
[73] rlang_0.2.0 pkgconfig_2.0.1 matrixStats_0.54.0 bindr_0.1 rstantools_1.5.1 htmlwidgets_1.0
[79] processx_3.2.0 magrittr_1.5 R6_2.2.2 multcomp_1.4-8 pillar_1.0.1 foreign_0.8-69
[85] mgcv_1.8-23 xts_0.11-1 abind_1.4-5 nnet_7.3-12 tibble_1.4.1 crayon_1.3.4
[91] car_2.1-6 grid_3.4.4 data.table_1.10.4-3 callr_3.0.0 threejs_0.3.1 digest_0.6.15
[97] xtable_1.8-2 httpuv_1.4.5 stats4_3.4.4 munsell_0.4.3 shinyjs_1.0 R2WinBUGS_2.1-21


#4

Could you try updating glue to the latest version (1.3.0)?


#5

Great. That did it :)
Thank you for your quick help.