Compatibility of cmdstan version with RHEL

Hello,

I have a question with regards to compatibility.
Does Cmdstan version 2.21.0 support RHEL 7.9, Kernel Version - 3.10.0-1160?

Thanks,
Aishwarya.G

That mostly depends on which compiler you have installed. The minimum g++ version that works with cmdstan 2.21.0 is g++ 4.9.3. If you have that you should be good.

1 Like

Thanks for your insight, Rok.

I’ve checked with g++ version, its:
g++ (GCC) 4.8.5 20150623 (Red Hat 4.8.5-39)

Currently using RHEL 7.7, will soon upgrade to RHEL 7.9
Do you think this will work? Or any suggestions

g++ 4.8.5 will unfortunately not work. I unfortunately do not know which compiler is the default compiler with rhel 7.9. But you could always upgrade the g++ compiler onyl if you have admin permissions.