Can't open MacOS R toolchain installer under Monterey

My system adamantly refuses to open the package. Ways to get around the problem under Catalina, given in the instructions, do not work under Monterey. I have Xcode and clang installed already. Do I need to run this installer at all?

which interface are you using?

which package? which instructions?

Thanks for your reply. I eventually figured out how to bypass the Apple security barrier and run the installer but it failed without any hint as to why. So I ended up installing rstan without installing the toolchain and it compiled and worked fine, maybe because I already had all the development tools installed. For me the installation instructions could have been more informative.

which installation instructions did you find? could you provide more details on what the problems were and what you did to solve them? this would help us improve the documentation and install instructions.

Sure. I wanted to install RStan, so I went to>Installation>RStan>RStan Quick Start Guide>Mac - Configuring C++ Toolchain which directed me to the MacOS R toolchain installer
My system (MacOS Monterey 12.4) refused to download the installer because of security concerns. That obstacle can be overcome but MacOS doesn’t tell you how, even if you click the little “?” bubble in the refusal box. For people like me who don’t run into this obstacle often, the RStan installation instructions could helpfully inform us that we can go to System Preferences > Security & Privacy > General where, for about an hour after a blocked download attempt, one can direct the system to open the installer anyway. I eventually figured that out and downloaded the installer, which is actually a package that gets fed to the MacOS Installer app. When I tried to run the installer it ran for a bit but then terminated with the message “Installation failed. Contact the software developer.” So I was stuck. But since I had the compiler and development tools already installed on my system, I thought that maybe I could just install the RStan package from R without successfully running’s toolchain installer, and that worked. RStan loaded, compiled, and ran. It appears that at least in some cases people like me who already have Xcode installed don’t need to run’s toolchain installer at all. Maybe the presence of an existing Xcode installation is what stops the installer. I don’t know. It would be helpful if the instructions cleared up this issue. Thanks for following up.

1 Like