Brms is not working properly

I am having several problems with Brms.
First, it stopped working (for reasons I didn’t discover) and to fix it I had to uninstall and delete everything related to R and update both R tools and R studio. Now it seems that it works, however two things happen that I can’t understand:

  1. When I run any brm() model the following message appears: Compiling Stan program…
    ‘-E’ not found.
    I have tried to find out “what’s going on” but I have been unable

  2. I’m running models that I already ran when it was working normally (a month ago), models that I checked 3 times each and brm() is giving me very different results, I don’t know if it has something to do with the first point, but it’s worrying.

My version of R: 4.0.3; Rstudio: 1.3.1093, rtools40; Windows 10

The -E warning is safe to ignore, its just a misconfiguration on our end that will be resolved in the next RStan release.

As for the inconsistent results, are you able to post a model and some data that reproduces the issue? That will be a big help with the debugging.

Also, do you see the same inconsistent results with backend="cmdstanr"?

1 Like

Hi Again, I have removed all my R stuff again and re-installed back. I cant figure out what happened but now the results I got are the same I get when I reppeat the process, so… I can’t say anything else, but I am happy that my results have landed…

Sorry and thank you so much!