Updated packages, brms has stopped working


#1

Hi,
I just updated a bunch of packages, including updating brms from 2.3.3 to 2.6. It now no longer runs correctly. If I begin to run a model I just get this and then it stops without running anything:

image

I don’t get any error.


#2

Can you try

library(rstan)
example(stan_model, run.dontrun = TRUE)

and tell us if there are more messages?


#3

Thanks, here’s what I get:


#4

I’m trying to update and reinstall rstan and Stanheaders and it seems to keep failing -


#5

Installing rstan seems to remove it but not reinstall an updated version:


#6

Try

install.packages("https://win-builder.r-project.org/tJ1528Lvo0H3/rstan_2.18.2.zip",
                  repos = NULL)

to install the rstan binary.


#7

Thanks - I did that (it worked), but now I get this error when trying to load the brms package:

Entry Point Not Found
The procedure entry point R_ContinueUnwind could not be located in the dynamic link library
C:\Users\pl39\Documents\R-3.4.4\library\rstan\libs\x64\rstan.dll


#8

Crap, I gave you the version for R 3.5. Restart R and then try

install.packages("https://win-builder.r-project.org/J1Fkw6nYyZwZ/rstan_2.18.2.zip",
                 repos = NULL)

#9

Cool, thanks, that worked. If I upgrade to a different version of R do I have to reinstall a different version of Rstan? I don’t recall it being an issue with past installations.


#10

In ordinary times, Windows will pick the binary version of the package that corresponds to the version of R that you are using.


#11

Great, thanks again for your help.


#12

I am having the exact same issue, but when I try to load rstan after installing using the script provided in this thread I get the following error

Error: package or namespace load failed for ‘rstan’:
package ‘rstan’ was installed by an R version with different internals; it needs to be reinstalled for use with this R version


#13

Never mind, I restarted R and repeated the suggested procedure and it worked.