51096 floating point exception (core dumped)

I have been using brms for a while and everything is fine. However, this afternoon, when I tried to use it, I got an error saying “51096 floating point exception (core dumped)”. I tried the simple example on Estimating Distributional Models with brms and still got the same error. I was wondering if anyone has any experience with this? I didn’t install any new package or update anything. Below is my session info:

R version 4.1.0 (2021-05-18)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Ubuntu 18.04.5 LTS

Matrix products: default
BLAS:   /usr/lib/x86_64-linux-gnu/blas/libblas.so.3.7.1
LAPACK: /usr/lib/x86_64-linux-gnu/openblas/liblapack.so.3

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] brms_2.15.0 Rcpp_1.0.7 

loaded via a namespace (and not attached):
 [1] nlme_3.1-152         matrixStats_0.60.0   xts_0.12.1          
 [4] threejs_0.3.3        rstan_2.21.2         backports_1.2.1     
 [7] tools_4.1.0          utf8_1.2.2           R6_2.5.0            
[10] DT_0.18              DBI_1.1.1            mgcv_1.8-36         
[13] projpred_2.0.2       colorspace_2.0-2     withr_2.4.2         
[16] tidyselect_1.1.1     gridExtra_2.3        prettyunits_1.1.1   
[19] processx_3.5.2       Brobdingnag_1.2-6    curl_4.3.2          
[22] compiler_4.1.0       cli_3.0.1            shinyjs_2.0.0       
[25] colourpicker_1.1.0   scales_1.1.1         dygraphs_1.1.1.6    
[28] mvtnorm_1.1-2        ggridges_0.5.3       callr_3.7.0         
[31] StanHeaders_2.21.0-7 stringr_1.4.0        digest_0.6.27       
[34] minqa_1.2.4          base64enc_0.1-3      pkgconfig_2.0.3     
[37] htmltools_0.5.1.1    lme4_1.1-27.1        fastmap_1.1.0       
[40] htmlwidgets_1.5.3    rlang_0.4.11         shiny_1.6.0         
[43] generics_0.1.0       zoo_1.8-9            jsonlite_1.7.2      
[46] crosstalk_1.1.1      gtools_3.9.2         dplyr_1.0.7         
[49] inline_0.3.19        magrittr_2.0.1       loo_2.4.1           
[52] bayesplot_1.8.1      Matrix_1.3-4         munsell_0.5.0       
[55] fansi_0.5.0          abind_1.4-5          lifecycle_1.0.0     
[58] stringi_1.7.3        MASS_7.3-54          pkgbuild_1.2.0      
[61] plyr_1.8.6           grid_4.1.0           parallel_4.1.0      
[64] promises_1.2.0.1     crayon_1.4.1         miniUI_0.1.1.1      
[67] lattice_0.20-44      splines_4.1.0        ps_1.6.0            
[70] pillar_1.6.2         igraph_1.2.6         boot_1.3-28         
[73] markdown_1.1         shinystan_2.5.0      codetools_0.2-18    
[76] reshape2_1.4.4       stats4_4.1.0         rstantools_2.1.1    
[79] glue_1.4.2           V8_3.4.2             RcppParallel_5.1.4  
[82] vctrs_0.3.8          nloptr_1.2.2.2       httpuv_1.6.1        
[85] gtable_0.3.0         purrr_0.3.4          assertthat_0.2.1    
[88] ggplot2_3.3.5        mime_0.11            xtable_1.8-4        
[91] coda_0.19-4          later_1.2.0          rsconnect_0.8.18    
[94] tibble_3.1.3         shinythemes_1.2.0    gamm4_0.2-6         
[97] ellipsis_0.3.2       bridgesampling_1.1-2
1 Like

did you do some updates to your Linux installation? Sometimes you need to recompile (reinstall) Stan from source after system updates as Stan on Linux links against system-wide libraries and if those change, it may crash… Could you try if that helps?

1 Like

Thank you for your reply. I think someone updated some packages on the server, which caused this problem. I solved this problem by re-installing the rstan package.