Trouble installing cmdstan with cmdstanpy

I’m trying to install cmdstan using cmdstanpy.install_cmdstan. I’m getting the following error:

In [1]: import cmdstanpy
In [2]: cmdstanpy.install_cmdstan()
INFO:cmdstanpy:CmdStan version: 2.26.1
INFO:cmdstanpy:Install directory: /Users/demetri/.cmdstanpy
INFO:cmdstanpy:Building cmdstan-2.26.1 binaries
INFO:cmdstanpy:Command "make build" failed
INFO:cmdstanpy:ld: warning: directory not found for option '-L/Users/demetri/.cmdstanpy/cmdstan-2.26.1/stan/lib/stan_math/lib/tbb'
INFO:cmdstanpy:ld: unsupported tapi file type '!tapi-tbd' in YAML file '/Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk/usr/lib/libSystem.tbd' for architecture x86_64
INFO:cmdstanpy:clang-10: error: linker command failed with exit code 1 (use -v to see invocation)
INFO:cmdstanpy:make: *** [bin/stansummary] Error 1
WARNING:cmdstanpy:CmdStan installation failed
Out[2]: False

The error says something about an unsupported file type in the MacOSX10.15 SDK. I’ve removed the CommandLineTools and reinstalled them and still the error persits.

I’m running MacOS 10.15.7 on a 2017 27 inch iMac.

Did you try this solution? (You probably did?)

Yes, tried that solution as well as a re installation of cmdstanpy. Same error persists

Solution was to just create a new conda env. Not ideal, but it worked.