Seems to be permissions error but uncertain

My issue seems to be rooted in the same problem this person was having only my computer is my personal computer and thus, I am wondering what permissions I might have to change in order to get it to run accordingly, assuming that is the issue: Permissions error running brms on Windows with "cmdstanr" backend

Install_cmdstan() wasn’t working for me, so I had to install via terminal, but then I set my path, and that seemed to be fine.

set_cmdstan_path(path = "/Library/Frameworks/R.framework/Versions/4.3-arm64/Resources/library/cmdstan")

cmd_mod <- cmdstan_model("brms.stan",
                         force_recompile = TRUE,
                         compile = TRUE)

cmd_fit <- cmd_mod$sample(
  data = stan_data,
  seed = 123,
  chains = 4,
  parallel_chains = 4,
  iter_sampling = 100,
  refresh = 100 # print update every 500 iters

This is the error I’m getting:

If possible, add also code to simulate data or attach a (subset of) the dataset you work with.

Operating System: Ventura 13.2.1
Interface Version: brms 2.19.0
Compiler/Toolkit: cmdstanr: 0.5.3

Just following up on this if anyone can offer any advice!

What was the issue you had with install_cmdstan()?

Thanks…just tried to reinstall and this is the output:

That indicates an internet connection issue, R is only able to download part of the release before the connection is terminated. Are you able to try a different network?

Interesting…I tried on two separate networks, but then used a hotspot on my phone after your advice, and that worked. Everything ran…now just need to troubleshoot model stuff!