RStudio running extremely slow with Stan file open

I am have some extreme problems using Ratudio to edit Stan files and then use Rstudio to run my code. My M2 MacBook Pro was running RStudio just fine with r code and Stan files but since the beginning of September saving, editing, running code, anything becomes extremely slow when I have a Stan file open in RStudio. I have tried uninstalling R and RStudio. I have tried older versions of both. I have updated to the most current version of the rstan library. I even reinstalled my OS to see if that fixes the problem. Nothing is working. For example, when I have a Stan file open to edit my model, it takes a few minutes to save changes. Then when I just have the Stan file open, it takes minutes to save r code scripts.

I posted to the RStudio help forum, but I figured it would help to post here to see if others have this problem. I can’t figure out how to report this peobelm to RStudio through email or other help besides their help forum. Any help would be appreciated. It has become a large problem to get work done.

I had this same issue about 1.5 ago on an M1 MBP. There was a lot of discussion with a wide range of suggestions that seemed to work for some people, some of the time:

The intermittent behavior made it difficult to tell if any of these solutions were really working for me. After 1-2 weeks of frustration, installing the development versions of StanHeaders, rstan, and cmdstanr seemed to do the trick. I haven’t had a recurrence since. I wasn’t able to pin down what was happening, so it’s impossible for me to know what it was about my ‘recipe’ that ultimately worked. The open issue on the rstan repo and the lengthy post-closure discussion on the rstudio repo suggest that it may still not be resolved despite quieting down recently. I’m staying tuned to this thread in hopes that someone does know how to fix this.

I am glad that I am not the only person… misery loves company and at least I am not going crazy. Thank you for pointing me to the threads. I will have to try some of these things.

I tried some of the fixes. Didn’t seem to work for me. I did try the experimental builds of the Stan headers and Rstan and that seemed to help some but I get an error about the v8 package not being installed???