Rstan on Windows

Wow that’s kinda nutty, thanks for the info tho’!

The OP instructions makes my model compile. Running now.

1 Like

The URL for rstan in the OP returns a 404 error.

Yeah the rstan url does seems to be out of date, sorry. @bgoodri do you have fresh urls? Can the binaries be posted somewhere less temporary?


Updated the OP

I have to point out that mine didn’t work with everything after -mtune-native. I removed that. The main model compiled but not the “projection model” which uses the output from the main model to generate quantiles etc.


Unfortunately now the url for installing the updated Stanheaders library is non-funcitonal (404 error)

@Tim_Tinker sorry about that. @bgoodri do you have fresh links?

Yeah, winbuilder is being slow so I had to do the 4.x ones on R-hub.

@bgoodri Thanks. @Tim_Tinker does installing using the now updated links work for you?

Yes that works now. Have installed both and updated the Makevars file, and now both custom stan models and rstanarm stan_glmer models all seem to be compiling and fitting just fine with R 4.0.2 and Rstudio Version 1.3.1054

Great, glad that it’s working and thanks for letting us know. Sorry for the hassle!

Hi @jumbo, I’m sorry to hear that.

Did you mean to respond in a different thread? This one is about RStan.

I don’t see where anyone claimed that.


I am using windows 10 and R 4.x and have ran the code specific to that. I also ran the “file.edit()” chunks in the R terminal and skipped “Sys.setenv()”.

When I try to compile my stan model (which is the one in the toturial about schools (schools.stan) I get the following error message:

Error in withr::set_makevars(new, path, state, assignment = assignment) :
Multiple results for CXX14FLAGS found, something is wrong.FALSE

What could be the problem with this?

Edit your file

M <- file.path(Sys.getenv("HOME"), ".R", ifelse(.Platform$OS.type == "windows", "", Makevars"))


and remove the older lines

@stevebronder Is this related to the recent PR? I guess withr errors if there are multiple of the same named entries?

What do you mean by older lines?

@Kasper_Fischer What do you see when you execute the code provided in my previous post ?

There is no messages when I run the code from your previous code, but the model still won’t compile. I am not sure about the step about removing older lines, however. What does that entail?