Rstan not available in R 3.3.0

Hi all,

I have been trying to run some Stan models that I have worked with previously and now out of the sudden I can not install the package rstan. I have updated the R version, although it was suggested that version 4.2.0 could not work. Hence, I have installed version 3.3.0 which was the one that the new version of Rstudio suggested. However, I keep on having the following message:

I have tried the following:

  1. Restart rstudio and physically close it.
  2. Install Rtools under the version 4.0
  3. Call the stan package from the github (stan website).

I haven’t been successful with any of these options. Any suggestions?

Hi Irene,

From looking at rstan’s github repo DESCRIPTION, it seems that rstan requires version 3.4.0 of R or later, which is why you can’t install it in R 3.3.0. I assume that when you say that version 3.3.0 “was the one that the new version of Rstudio suggested” you mean that on the R studio downloads website it says that it requires R 3.3.0+, but that means that it will work with any version of R as new or newer than 3.3.0, so I would highly suggest using a more updated version of R (like R 4.1.3). With a newer version of R installed, you should be able to install rstan.

1 Like

Thanks! It is solved already.