New error: cleanup_makevar(old) : argument "RMU" is missing, with no default

Hi all,

After moving to R 4.0 and the most recent version of STAN, I’m getting a really strange error while trying to compile using stan_model. The process throws an error with:

Error in cleanup_makevar(old) : argument "RMU" is missing, with no default. 

Google and searching these forums didn’t turn up any insights. I’ve reinstalled my toolchain and removed all prior versions of R and RTools, and tried a couple alterations to the Makevars files.

devtools::session_info("rstan") flags an issue with the RcppParallel package with:
D -- DLL MD5 mismatch, broken installation. Unsure if that is relevant.

Last, here are the key bits of session info:

  • version R version 4.0.2 (2020-06-22)
  • os Windows 10 x64
  • system i386, mingw32

Thanks in advance for any and all help!

I’m also getting this warning, which as I understand can be safely ignored, but I’m including it to be comprehensive.

In system(paste(CXX, ARGS), ignore.stdout = TRUE, ignore.stderr = TRUE) :
‘C:/rtools40/usr/mingw_/bin/g++’ not found

I encountered this same problem yesterday after updating to the latest version of rstan and Stanheaders. It seemed to appear when attempting to add or remove generated quantities from my STAN code. I’m reinstalling R4.0, Rtools40 and rstan (in that order) right now to see if that might fix it…will update soon.

Just ran into this error too - i’m super new to using rstan but have exactly the same issues as above and nothing worked in terms of unistalling and re-installing or changing the marevars files - eagerly awaiting some news

1 Like

After reinstalling R4.0, RTools40 and doing a source install of the rstan package I’m no longer getting the cleanup_makevar issue, but I am getting another issue where rstan seems to think I’m allocating gigantic vectors! I made another post about it here:

But figured I’d comment here as well in case the root issue is still the same.

1 Like

Sorry you’re all running into this error. I’m not sure what’s going unfortunately. Tagging @stevebronder and @bgoodri in case they haven’t seen this yet. Looks like this is related to the makevars processing stuff and you both know that code better than I do. Can you take a look when you have a chance? Thanks!

Some is this is certainly my bad, what version of rstan is this? Was it installed from CRAN or github? I can take a look tmrw morning

1 Like

Having the same error. Have re-installed everything to the latest versions - to no avail.

“RMU” is missing, with no default

Getting the same error with rstan 2.21.2 from Cran.
system x86_64, mingw32
version.string R version 4.0.2 (2020-06-22)

I was getting this error as well, but only on one computer when my other which had the same version of rstan (2.21.2) was doing fine. Both on Windows 10 and R 4.0.2. The only loaded packages which seemed to be different on the two computers were jsonlite, withr, inline, processx and callr. So I changed back to jsonlite 1.7.0, withr 2.2.0 and inline 0.3.15 and the error no longer appears. I also reinstalled processx and callr which might have changed something somewhere.


Rolling backed these packages worked for me.

Do you know what version of withr you had before? I think we just have to add withr to depends and tag at least version 2.2.0

@stevebronder I was using the CRAN version of rstan. I can try to install from Github as well.

Given what @fseaton mentioned about other loaded packages, I had some issues installing withr that could be contributing. I’m using withr 2.3.0.

It was withr version 2.3.0 that didn’t work, so I assume something changed with that update as 2.2.0 is working fine

Alright I just updated I’ll test it out now

Do you have anything in your Makevars file? It’s an odd error because its coming from the function here to cleanup any changes to the local makevars.

Just to confirm, this does not happen for withr 2.2.0 for you? I’m testing this locally now and the version on github is working for 2.3.0 on my ubuntu machine

1 Like

Does 2.2.0 work? How did you install the old version of “withr”?

I configured Makevars based on the Rstan getting started wiki. That doesn’t appear to be the issue.

Moving to withr 2.2.0 solved the issue with the CRAN version of Rstan. I was trying to install from Github to check withr 2.3.0 and had a couple errors that seem tied to StanHeaders.

In utils::untar(tarfile, ...) : ‘tar.exe -xf "C:\Users\Josh\AppData\Local\Temp\Rtmp4YUBmm\filee745f825d.tar.gz" -C "C:/Users/Josh/AppData/Local/Temp/Rtmp4YUBmm/remotese747b221d95"’ returned error code 1

Therefore I may just stick to withr 2.2.0 and rstan from CRAN, and then update everything later.

@HCOKSTATE you can download the binary files for withr 2.2.0 here.

Thanks for your suggestion @jkalley . It works after I re-install the 2.2.0 package. But I still get a warning saying “Warning message:
In system(paste(CXX, ARGS), ignore.stdout = TRUE, ignore.stderr = TRUE) :
‘-E’ not found”.
I do not know whether it is matter.

That’s fine it’s just a warning.

My makevars has this:

CXX14FLAGS=-O3 -mtune=native -mmmx -msse -msse2 -msse3 -mssse3 -msse4.1 -msse4.2

If I remove the Makevars file it works, and if the Makevars file is present but empty it works. It doesn’t work with just CXX14FLAGS=-O3 in the Makevars file but I haven’t done any more testing. It always works with withr version 2.2.0. Maybe a windows specific issue if it works on ubuntu?

I’ve just checked and the github version of withr doesn’t work either.

1 Like