Math - tbb.dll not found

While trying to setup the new windows machine I ran into the below error when running -j16 test/unit.

Note this is on a clean windows machine.

Please let me know if you need any debug information like cpu, gpu, path etc.

Steps to reproduce:

@wds15 @seantalts

Does this happen on a specific machine+setup since recently?

I mean, I wonder how this is coming up now as it did not show up after we fixed this. Any clue what changed? Does this happen with the released 3.0 math?

The error suggests that the tbb.dll is not in the PATH variable or the other solution is to copy the tbb.dll into the same directory as the executable which is failing. The copying should be handled by the makefiles automatically.

I had the same problem (using the yesterday’s develop). I just assumed this is business as usual (something requiring additional setup on Windows), put lib/tbb on PATH and went on with my business. I have Win 10, using g++ from Rtools and running within Anaconda’s shell (to have Python).

I think this on a new dedicated Windows machine @serban-nicusor is trying to set up.

@serban-nicusor If you run the Math tests directly you need to set up the PATH variable, like Sebastian and Marting alredy mentioned.

If run through jenkins this handles this for you:

1 Like

This is currently making the cmdstan Windows interface tests on Jenkins:

You are right @rok_cesnovar
I totally missed that and didn’t find it in the Math docs anywhere so I assumed it’s done automatically.

@mcol I see that CmdStan is missing the part @rok_cesnovar mentioned above

@wds15 It’s on a clean machine which uses binaries from Rtools. I’ve made it exactly as the windows machine we already have. But I didn’t add tbb.dll in the PATH by myself nor it was done automatically. It was on yday develop branch.

1 Like

Ah… now it starts to make sense. Sorry, I forgot that for Stan-math we need to set the PATH variable.

We need better doc for this apparently.

I got the following when trying to use the install-tbb command.


  • Not an Administrator account
  • Ran from CMD not as Administrator
  • Windows Version 1809 OS Build 17763.864

Note: It didn’t add tbb to my PATH
Current Path:

C:\Program Files\Microsoft MPI\Bin\
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.1\bin
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.1\libnvvp
C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common
C:\Program Files\NVIDIA Corporation\Nsight Compute 2019.4.0\
C:\Program Files\MiKTeX 2.9\miktex\bin\x64\
C:\Program Files\Pandoc\
C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit\
C:\Program Files\Git\cmd
C:\Program Files (x86)\Intel\IntelSGXSDK\bin\x64\Release\
C:\Program Files (x86)\Intel\IntelSGXSDK\bin\win32\Release\
C:\Users\jenkins\AppData\Local\Programs\MiKTeX 2.9\miktex\bin\x64\
C:\Users\jenkins\AppData\Local\Programs\Microsoft VS Code\bin
C:\Users\jenkins\Desktop\cmdstan>mingw32-make install-tbb
cmd.exe /C install-tbb.bat
Permanently setting the PATH user environment variable:
ERROR: Invalid syntax. Default option is not allowed more than '2' time(s).
Type "SETX /?" for usage.
Please close this shell and open a new shell.
This will make the changes to the PATH variable
become active.
1 Like