Issue with disabling of VTables in PCH file currently being enabled

Hi all,

I’m on MacOS: 11.2.1
cmdstanr: 2.27.0

I’m trying to use a package, Aria (GitHub - mike-lawrence/aria: An R package implementing an idiosyncratic Stan workflow), which uses cmdstanr. I get the following warning when running with Aria but not when I just use cmdstanr, but the developer of the Aria package, Mike, a member here, suggested that the issue was actually with cmdstanr.

Haven’t been able to find anything with this particular error, it does look like putting rebuild_cmdstan() in the cmdstanr function call has helped people, but in my particular case, I can’t put this in the Aria function call.

ensure model is compiled


data = data_for_stan
, code_path = mod_path
, out_path = post_path
, overwrite = T
, block = T

mymodel_obj ← cmdstan_model(mod_path, cpp_options = list(stan_threads = TRUE))

post ← mymodel_obj$sample(data_for_stan, chains = 4, refresh = 1,
output_dir = “.”, validate_csv = FALSE,

Could add actual data and code, but there’s a lot of code, so seeing whether anyone has experienced a similar issue or might know how to fix this particular error.

Thanks much!


Can you try running:


And then try your aria call again?

Shoot, this is probably bc aria compiles the “performance” exe with a few optimization flags set as a hard default:

			, 'CXXFLAGS += -O3'
			, 'CXXFLAGS += -g0'
			, 'STAN_CPP_OPTIMS=true'

and I’ve only been testing those on Linux, so I suspect MacOS doesn’t like one of them. I’ll push an update later today to have a better paradigm for users diverging from these defaults.

Thanks, Andrew. Just tried that. No dice. Will wait to hear back from Mike. Thanks!

Sorry for the delay. Just pushed an update to aria, can you try installing again? Either by renv::install_github('mike-lawrence/aria/aria') or by downloading the package tar.gz and using the RStudio GUI to install-from-local-source.

Thanks, Mike!

Was able to install using remotes::install_github(‘mike-lawrence/aria/aria’). I was still getting the same error:

I then tried downloading the linked tar and installing it from the GUI. I was able to install it; however, I get the same error as above.

Ok, I pulled out the final set of default optimizations and added a mechanism for the user to add them by hand instead. Want to try again?

Just tried…so I think that issue is fixed:

When running the composed model, though:


data = data_for_stan
, code_path = mod_path
, out_path = post_path
, overwrite = T
, block = T

I get the error:

But we can resolve this through PM. Thanks!

1 Like