Installation fails of projpred fails on MacOS

Hi all, i’m trying to install projpred in Rstudio (Version 2023.06.0+421 (2023.06.0+421)) wit R version 4.3.1 (2023-06-16) on MacOS (Ventura 13.2.1) with an Intel Core i5. When I try to install i get an error, in particular i get this:

> install.packages("projpred")
trying URL ''
Warning in install.packages :
  downloaded length 0 != reported length 0
Warning in install.packages :
  cannot open URL '': HTTP status was '404 Not Found'
Error in download.file(url, destfile, method, mode = "wb", ...) : 
  cannot open URL ''
Warning in install.packages :
  download of package ‘projpred’ failed

Is there any way i can resolve this?

Thanks in advance!

Hi Alessio,

What surprises me is the projpred version in your output: It is 2.5.0, but the most recent CRAN version is 2.6.0. Could you try 2.6.0 from CRAN - Package projpred?

Thanks Frank,

it worked if i downloaded the .tgz file from CRAN and installed from my machine. However, it doesn’t work if i try to installing it with install.packages() nor if I tried it with devtools::install_version() so I thought I mention it. By manually installing it works! Thanks a lot for the suggestion!

No problem and great to hear it works this way. I think it is probably related to some CRAN or CRAN mirror (in your case problem, so we probably can only wait for a solution from their side.