BRMS running time

fitting-issues
performance

#21

I will do that, thanks a lot.
Please let me know whenever you think there is something I could usefully add to the model, as I will be running the same analysis on many similar data frames in the next weeks.
Thanks again!


#22

the model I run which lasted 10 hours gave these results:

There were 4000 transitions after warmup that exceeded the maximum treedepth. Increase max_treedepth above 10. See
http://mc-stan.org/misc/warnings.html#maximum-treedepth-exceededExamine the pairs() plot to diagnose sampling problems
The model has not converged (some Rhats are > 1.1). Do not analyse the results! 
We recommend running more iterations and/or setting stronger priors.

I will now rerun using
prior = prior(normal(0, 5), class = "b")
and
stan(..., control = list(max_treedepth = 15))
and see how it goes.
Sorry for updating you, its the first time I use it and its for my PhD, and thought you might advise in case I am doing anything wrong.
Thank you


#23

Sorry to bother you again, Paul, but its been two days trying to figure out the cause of this error with no results.

Error in check_autocor(autocor) : '...' used in an incorrect context
My model is :

modA <- brm(
Change ~ Pretest + Group + PoS + Verbal_freq + Band_freq + Imageability + Cognateness + Characters + Syllables + (1|Subject) + (1| Word),
stan(..., control = list(max_treedepth = 15)),
data = wf.ChangeDV.PreCov,
family = 'categorical',
prior = prior(normal(0, 5), class = "b"))

Could you please advise me on this?


#24

The stan(...) stuff should not be there. Instead, go for

modA <- brm(
Change ~ Pretest + Group + PoS + Verbal_freq + Band_freq + Imageability + Cognateness + Characters + Syllables + (1|Subject) + (1| Word),
data = wf.ChangeDV.PreCov,
family = 'categorical',
prior = prior(normal(0, 5), class = "b"),
control = list(max_treedepth = 15))

#25

It worked! Thank you very much and happy new year : )