Troubles with Discourse


#21

The number on the top right are notifications (mentions, likes, etc) and I believe that the number on the top left is new messages.


#22

You mean turn off sending an email when someone writes @Bob_Carpenter? Click your picture in the upper-right, click the gear, click on “email” from the LHS menu, then there’s an option for “Send me an email when someone quotes me, replies to my post, mentions my @username, or invites me to a topic” , if you turn that off the @ won’t work anymore. There are a few other relevant options in there.

No… you mean people are sending you direct messages? That’s silly, no idea how to turn that off.


#23

I mean turn off the ability of people to send me private messages through GitHub. I have all the email turned off becuase the interface is so broken. I’m getting daily personal messages and I don’t want to have to keep sending people form letters telling them to post their questions publicly.


#24

You mean private messages on Discourse?

I looked into it but there doesn’t seem to be any way to disable or otherwise modify messaging capabilities.


#25

Yes, I mean private messages on Discourse (not GitHub—crosstalk from the old list GitHub discussion!). I also couldn’t see a way to disable them.


#26

I was referring to the admin side of things. But it definitely looks like there are not ways to disable messaging from either the user or admin side at the moment.

The extent to which users will go to avoid asking questions in public!


#27

Looks like the discourse devs are on this one:

Also, in general, check meta.discourse.org – chances are they have
already fixed it and/or there is an open issue.


#28

I believe we can shut down private messages for everyone. Or we can shut it down for people with less than a certain trust level with the current state of Discourse.


#29

Discourse is messing up manual enumerations. Try to type in:

1. asdf

asdfasdf

2. asdf

You need the text in the middle, the extra newlines, and the spaces between the periods and the words afterwards. It will produce:

1. asdf

asdfasdf

1. asdf

#30

I can imagine that private messages might be useful in some cases.
Perhaps we could just restrict it to a certain trust level.

Let’s restrict it to level 2 and see if that helps? Or should we jump to
3? Perhaps Bob has some thoughts here?

Here’s the list of trust levels and how you can get them:


#31

I didn’t see the trust limitation in the admin before – I set it to Level 2 before you can send a private message. That should hopefully be enough to prevent new users from messaging people instead of creating a new topic.


#32

@bbbales2

It’s a markdown thing.

This will work:

  1. first item, first line
    first item, second line

  2. second line

and this wont:

  1. first item, first line

    first item, second line

  2. second line

Notice: no blank line between the first and second line.


#33

Git flavored markdown works this way. You need to indent tha second line four spaces, as in

1. foo
    bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar <p>bar bar bar bar bar bar bar bar bar bar 
1. Here's number two.

which renders as


  1. foo
    bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar bar

    bar bar bar bar bar bar bar bar bar bar

  2. Here’s number two.

Note the <p> for the paragraph break rather than the double spaces.

I’m not a huge fan of markdown, but then I’ve been dealing with raw HTML since the web opened for business in the early 90s.


#34

D’oh, juked hard by web tech. Thanks


#35

Ah, I think I’ve found the proximate cause of our problems. When I replied to Sean a third time, Discourse started nagging me to reply to others and came up with this gem of advice:

Consider replying to more people

You’ve already replied 3 times to @seantalts in this particular topic.

Have you considered replying to other people in the discussion, too? A great discussion involves many voices and perspectives.

If you’d like to continue your conversation with this particular user at length, send them a personal message.

My emphasis. Any way we can remove this? It’s not the advice we want to send users and may explain why I’m getting so many off-list personal messages.


#36

Yup. Found the setting. It’s called get a room threshold. I found it by googling the error message, finding the discourse source, then backing out the setting: https://github.com/discourse/discourse/blob/master/config/locales/server.en.yml

There’s still a threshold, but I set it to 1000.


#37

Thanks!


#38

Is there any way to turn off the bad highlighting we’re getting, as in the following:

int<lower=0, upper=1> foo;

I guess it thinks I’m trying to send a ransom note.


#39

I just tried updating the recognized languages. Let’s see if this changes anything. This is with auto language detection:

int<lower=0, upper=1> foo;

This adds “Stan” as the language:

int<lower=0, upper=1> foo;

#40

I just changed the default to Stan.

int<lower=0, upper=1> foo;